<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.altustimes.com/xmlrpc.php" />
<title>Local sports round-up | Altus Times</title>

<!-- Start The SEO Framework by Sybre Waaijer -->
<meta name="robots" content="noydir" />
<meta name="description" content="Local sports round-up on Altus Times | Lady Indians get back in the win columnAfter a four-game stretch in which the Navajo Lady Indians fast pitch softball team fell victim to Lookeba-Sickles, Mangum twice and Snyder, the Lady Indians got back into the win column on Tuesday with a, 16-0, win over the&#8230;" />
<meta property="og:image" content="https://s24467.pcdn.co/wp-content/uploads/2018/04/cropped-altus.png" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="72" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Local sports round-up | Altus Times" />
<meta property="og:description" content="Lady Indians get back in the win columnAfter a four-game stretch in which the Navajo Lady Indians fast pitch softball team fell victim to Lookeba-Sickles, Mangum twice and Snyder, the Lady Indians got&#8230;" />
<meta property="og:url" content="https://www.altustimes.com/sports/18377/local-sports-round-up" />
<meta property="og:site_name" content="Altus Times" />
<meta property="article:published_time" content="2018-09-01T10:45-04:00" />
<meta property="article:modified_time" content="2018-09-01T10:45-04:00" />
<meta property="og:updated_time" content="2018-09-01T10:45-04:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Local sports round-up | Altus Times" />
<meta name="twitter:description" content="Lady Indians get back in the win columnAfter a four-game stretch in which the Navajo Lady Indians fast pitch softball team fell victim to Lookeba-Sickles, Mangum twice and Snyder, the Lady Indians got&#8230;" />
<meta name="twitter:image" content="https://s24467.pcdn.co/wp-content/uploads/2018/04/cropped-altus.png" />
<meta name="twitter:image:width" content="300" />
<meta name="twitter:image:height" content="72" />
<link rel="canonical" href="https://www.altustimes.com/sports/18377/local-sports-round-up" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.altustimes.com","name":"Altus Times"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.altustimes.com/category/sports","name":"Sports"}},{"@type":"ListItem","position":3,"item":{"name":"Local sports round-up"}}]}</script>
<!-- End The SEO Framework by Sybre Waaijer | 0.00033s -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Altus Times &raquo; Feed" href="https://www.altustimes.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Altus Times &raquo; Comments Feed" href="https://www.altustimes.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Altus Times &raquo; Local sports round-up Comments Feed" href="https://www.altustimes.com/sports/18377/local-sports-round-up/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24467.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://s24467.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://s24467.pcdn.co/wp-content/themes/mh-magazine%20-%20Graystone/simple-staff-list-custom.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://s24467.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2018.08.01' type='text/css' media='all' />
<link rel='stylesheet' id='megamenu-css'  href='https://s24467.pcdn.co/wp-content/uploads/maxmegamenu/style.css?ver=176c2b' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s24467.pcdn.co/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s24467.pcdn.co/wp-content/themes/mh-magazine%20-%20Graystone/style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s24467.pcdn.co/wp-content/themes/mh-magazine%20-%20Graystone/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Sarala:300,400,400italic,600,700%7cAdamina:300,400,400italic,600,700' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://s24467.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-content/themes/mh-magazine%20-%20Graystone/js/scripts.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.altustimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.altustimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24467.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.altustimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.altustimes.com%2Fsports%2F18377%2Flocal-sports-round-up" />
<link rel="alternate" type="text/xml+oembed" href="https://www.altustimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.altustimes.com%2Fsports%2F18377%2Flocal-sports-round-up&#038;format=xml" />
<style type="text/css">#wpadminbar #wp-admin-bar-vfbp-toolbar-edit-form > .ab-item:before {content: "\f175";top: 2px;}#wpadminbar #wp-admin-bar-vfbp-admin-toolbar > .ab-item:before {content: "\f175";top: 2px;}</style><style type="text/css">
.mh-widget-layout4 .mh-widget-title { background: #1c63b7; background: rgba(28, 99, 183, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #1c63b7; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #1c63b7; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #1c63b7; }
</style>
<!--[if lt IE 9]>
<script src="https://s24467.pcdn.co/wp-content/themes/mh-magazine%20-%20Graystone/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Adamina", serif; }
body { font-family: "Sarala", sans-serif; }
</style>
<link rel="amphtml" href="https://www.altustimes.com/sports/18377/local-sports-round-up/amp">		<style type="text/css" id="wp-custom-css">
			.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}		</style>
	<style type="text/css">/** Mega Menu CSS: fs **/</style>
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=99474539"></script>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-18377 single-format-standard wp-custom-logo mega-menu-mh-main-nav mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-16392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16392"><a href="https://www.altustimes.com/paywall-subscribe">Subscribe</a></li>
<li id="menu-item-16387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16387"><a href="https://www.altustimes.com/e-edition">E-Edition</a></li>
<li id="menu-item-16685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16685"><a href="https://www.altustimes.com/circulars">Circulars</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.altustimes.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="72" src="https://s24467.pcdn.co/wp-content/uploads/2018/04/cropped-altus.png" class="custom-logo" alt="Altus Times" itemprop="logo" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-10" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget">						<ins data-revive-zoneid="16" data-revive-id="4cbd8d8221532000f73b24d326977365"></ins>
			<script async src="//graystoneads.midtc.com/www/delivery/asyncjs.php"></script></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div id="mega-menu-wrap-mh_main_nav" class="mega-menu-wrap"><div class="mega-menu-toggle" tabindex="0"><div class="mega-toggle-blocks-left"></div><div class="mega-toggle-blocks-center"></div><div class="mega-toggle-blocks-right"><div class='mega-toggle-block mega-menu-toggle-block mega-toggle-block-1' id='mega-toggle-block-1'><span class='mega-toggle-label'><span class='mega-toggle-label-closed'>MENU</span><span class='mega-toggle-label-open'>MENU</span></span></div></div></div><ul id="mega-menu-mh_main_nav" class="mega-menu max-mega-menu mega-menu-horizontal mega-no-js" data-event="hover_intent" data-effect="fade_up" data-effect-speed="200" data-effect-mobile="disabled" data-effect-speed-mobile="200" data-second-click="close" data-document-click="collapse" data-vertical-behaviour="standard" data-breakpoint="600" data-unbind="true"><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-home mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-4372' id='mega-menu-item-4372'><a class="mega-menu-link" href="https://www.altustimes.com" aria-haspopup="true" tabindex="0">Home<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4381' id='mega-menu-item-4381'><a class="mega-menu-link" href="https://www.altustimes.com/about-us">About Us</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4382' id='mega-menu-item-4382'><a class="mega-menu-link" href="https://www.altustimes.com/advertise">Advertise</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4383' id='mega-menu-item-4383'><a class="mega-menu-link" href="https://www.altustimes.com/contact-us">Contact Us</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4387' id='mega-menu-item-4387'><a class="mega-menu-link" href="http://www.facebook.com/pages/Altus-Times/123778499231">Altus Times on Facebook</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4388' id='mega-menu-item-4388'><a class="mega-menu-link" href="http://twitter.com/TheAltusTimes">Altus Times on Twitter</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4384' id='mega-menu-item-4384'><a class="mega-menu-link" href="https://www.altustimes.com/reader-services">Reader Services</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4385' id='mega-menu-item-4385'><a class="mega-menu-link" href="https://www.altustimes.com/sign-up-for-notices">Sign Up For Notices</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4386' id='mega-menu-item-4386'><a class="mega-menu-link" href="https://www.altustimes.com/subscribe">Subscribe</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-4373' id='mega-menu-item-4373'><a class="mega-menu-link" href="https://www.altustimes.com/category/news" aria-haspopup="true" tabindex="0">News<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-7267' id='mega-menu-item-7267'><a class="mega-menu-link" href="https://www.altustimes.com/president">President Trump</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4389' id='mega-menu-item-4389'><a class="mega-menu-link" href="https://www.altustimes.com/archives">Archives</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4390' id='mega-menu-item-4390'><a class="mega-menu-link" href="https://www.altustimes.com/circulars">Circulars</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4396' id='mega-menu-item-4396'><a class="mega-menu-link" href="http://www.myinvestkit.com/altustimes.com/">Finance</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4391' id='mega-menu-item-4391'><a class="mega-menu-link" href="https://www.altustimes.com/formnewstip">Submit News Tip</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4392' id='mega-menu-item-4392'><a class="mega-menu-link" href="https://www.altustimes.com/online-community">Online Community</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4393' id='mega-menu-item-4393'><a class="mega-menu-link" href="https://www.altustimes.com/onlineforms">Online Forms</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4394' id='mega-menu-item-4394'><a class="mega-menu-link" href="https://www.altustimes.com/specialsections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4395' id='mega-menu-item-4395'><a class="mega-menu-link" href="https://www.altustimes.com/rss">All Articles Feed</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-current-post-ancestor mega-current-menu-parent mega-current-post-parent mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-4374' id='mega-menu-item-4374'><a class="mega-menu-link" href="https://www.altustimes.com/category/sports" aria-haspopup="true" tabindex="0">Sports<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4397' id='mega-menu-item-4397'><a class="mega-menu-link" href="https://www.altustimes.com/formscores">Submit Scores</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4398' id='mega-menu-item-4398'><a class="mega-menu-link" href="https://www.altustimes.com/formsportsnews">Submit Sports News</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-5667' id='mega-menu-item-5667'><a class="mega-menu-link" href="http://pro32.ap.org/altustimes">Pro32</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-5668' id='mega-menu-item-5668'><a class="mega-menu-link" href="http://summergames.ap.org/altustimes">AP Olympics Coverage</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-5669' id='mega-menu-item-5669'><a class="mega-menu-link" href="http://racing.ap.org/altustimes">Auto Racing</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-5670' id='mega-menu-item-5670'><a class="mega-menu-link" href="http://collegebasketball.ap.org/altustimes">College Basketball</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-5671' id='mega-menu-item-5671'><a class="mega-menu-link" href="http://collegefootball.ap.org/altustimes">College Football</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-align-bottom-left mega-menu-flyout mega-menu-item-15958' id='mega-menu-item-15958'><a class="mega-menu-link" href="https://www.altustimes.com/category/obituaries" tabindex="0">Obituaries</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-4375' id='mega-menu-item-4375'><a class="mega-menu-link" href="https://www.altustimes.com/category/opinion" aria-haspopup="true" tabindex="0">Opinion<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-current-post-parent mega-menu-item-4399' id='mega-menu-item-4399'><a class="mega-menu-link" href="https://www.altustimes.com/formeditor">Submit Letter To The Editor</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-4376' id='mega-menu-item-4376'><a class="mega-menu-link" href="https://www.altustimes.com/category/features" aria-haspopup="true" tabindex="0">Features<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-5254' id='mega-menu-item-5254'><a class="mega-menu-link" href="https://www.altustimes.com/games">Puzzles & Games</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4400' id='mega-menu-item-4400'><a class="mega-menu-link" href="https://www.altustimes.com/comics">Comics</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4401' id='mega-menu-item-4401'><a class="mega-menu-link" href="https://www.altustimes.com/contests">Contests</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4402' id='mega-menu-item-4402'><a class="mega-menu-link" href="https://www.altustimes.com/horoscopes">Horoscopes</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4404' id='mega-menu-item-4404'><a class="mega-menu-link" href="https://www.altustimes.com/specialsections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4405' id='mega-menu-item-4405'><a class="mega-menu-link" href="https://www.altustimes.com/formanniversary">Submit Anniversary</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4406' id='mega-menu-item-4406'><a class="mega-menu-link" href="https://www.altustimes.com/formbirth">Submit Birth</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4407' id='mega-menu-item-4407'><a class="mega-menu-link" href="https://www.altustimes.com/formbirthday">Submit Birthday</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4408' id='mega-menu-item-4408'><a class="mega-menu-link" href="https://www.altustimes.com/formengagement">Submit Engagement</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4409' id='mega-menu-item-4409'><a class="mega-menu-link" href="https://www.altustimes.com/formwedding">Submit Wedding</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-4377' id='mega-menu-item-4377'><a class="mega-menu-link" href="https://www.altustimes.com/calendar" tabindex="0">Calendar</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-4378' id='mega-menu-item-4378'><a class="mega-menu-link" href="https://www.altustimes.com/entertainment" aria-haspopup="true" tabindex="0">Entertainment<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4415' id='mega-menu-item-4415'><a class="mega-menu-link" href="https://www.altustimes.com/tvlistings">TV Listings</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4413' id='mega-menu-item-4413'><a class="mega-menu-link" href="https://www.altustimes.com/tvsoaps">Soaps</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4410' id='mega-menu-item-4410'><a class="mega-menu-link" href="https://www.altustimes.com/tvgames">Games</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4411' id='mega-menu-item-4411'><a class="mega-menu-link" href="https://www.altustimes.com/tvmovies">Movies</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4412' id='mega-menu-item-4412'><a class="mega-menu-link" href="https://www.altustimes.com/tvqa">Q &#038; A</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4418' id='mega-menu-item-4418'><a class="mega-menu-link" href="https://www.altustimes.com/tvsports">TV Sports</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4419' id='mega-menu-item-4419'><a class="mega-menu-link" href="https://www.altustimes.com/tvtalk">TV Talk</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4414' id='mega-menu-item-4414'><a class="mega-menu-link" href="https://www.altustimes.com/tvbestbets">TV Best Bets</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4416' id='mega-menu-item-4416'><a class="mega-menu-link" href="https://www.altustimes.com/tvnews">TV News</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4417' id='mega-menu-item-4417'><a class="mega-menu-link" href="https://www.altustimes.com/tvsearch">TV Search</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4420' id='mega-menu-item-4420'><a class="mega-menu-link" href="https://www.altustimes.com/tvvideo">TV Video</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-align-bottom-left mega-menu-flyout mega-menu-item-4379' id='mega-menu-item-4379'><a class="mega-menu-link" href="http://local.altustimes.com" tabindex="0">Businesses</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-16399' id='mega-menu-item-16399'><a class="mega-menu-link" href="https://www.altustimes.com/weather" tabindex="0">Weather</a></li></ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-date mh-header-date-bottom">
							September 1, 2018						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside zoomdSearch='{"trigger":"OnClick"}' class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.altustimes.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.altustimes.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.altustimes.com/category/sports" itemprop="url"><span itemprop="title">Sports</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Local sports round-up</nav>
<style>
.neFileBlock{
	display:none;
}
</style>

<article id="post-18377" class="post-18377 post type-post status-publish format-standard hentry category-sports">
	<header class="entry-header clearfix"><h1 class="entry-title">Local sports round-up</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.altustimes.com/date/2018/09">September 1, 2018</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.altustimes.com/author/englewoodindependent">altustimes</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.altustimes.com/category/sports" rel="category tag">Sports</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.altustimes.com/sports/18377/local-sports-round-up#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="18377 https://www.altustimes.com/?p=18377">0</span></a></span>
</div>
				<div id="byline" style="margin-left: 5px; margin-top: 5px;"><b> By Ryan Lewis - ryan@altustimes.com</b></div>
			</header>
					
			<div class="mh-excerpt"><p>Lady Indians get back in the win column After a four-game stretch in which the Navajo Lady Indians fast pitch softball team fell victim to Lookeba-Sickles, Mangum twice and Snyder, the Lady Indians got back <a class="mh-excerpt-more" href="https://www.altustimes.com/sports/18377/local-sports-round-up" title="Local sports round-up">[&#8230;]</a></p>
</div>			<hr />
			<h4>Please login below. If you do not have a login, please <a href="/subscribe">subscribe</a></h4>
			<form action="https://midtc.com/pcore/altus/validate.php" id="login" method="post" style="font-family:Roboto;">
				E-Mail Address:<br><input type="text" name="username"><br>
				Password:<br><input type="password" name="password"><br>
				<button type="submit" form="login" value="Submit">Login</button>
				<input type="hidden" value="https://www.altustimes.com/sports/18377/local-sports-round-up" name="url">
			</form>
			<hr />
		</article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.altustimes.com/news/18376/council-discusses-capital-improvements-metering-bulk-trash" rel="prev"><span>Previous</span><p>Council discusses capital improvements, metering, bulk trash</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.altustimes.com/sports/18379/smith-fans-6-in-indians-10-2-win-over-hydro-eakly" rel="next"><img width="80" height="60" src="https://s24467.pcdn.co/wp-content/uploads/2018/09/web1_Mitch-Smith-CMYK_ne201883011400134-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://s24467.pcdn.co/wp-content/uploads/2018/09/web1_Mitch-Smith-CMYK_ne201883011400134-80x60.jpg 80w, https://s24467.pcdn.co/wp-content/uploads/2018/09/web1_Mitch-Smith-CMYK_ne201883011400134-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Next</span><p>Smith fans 6 in Indians 10-2 win over Hydro-Eakly</p></a></div>
</nav>

<div id="disqus_thread"></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-2" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget">	<ins data-revive-zoneid="12" data-revive-id="4cbd8d8221532000f73b24d326977365"></ins>
				<script async src="//graystoneads.midtc.com/www/delivery/asyncjs.php"></script>		</div></div><div id="custom_html-15" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=85722" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="height: 20px;margin: -20px 0 0 0;text-indent: -9999em;z-index: 1;display: block;position: relative" href="/weather" rel="nofollow">Altus weather forecast</a></div></div></div><div id="custom_html-4" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="13" data-revive-id="4cbd8d8221532000f73b24d326977365"></ins>
				<script async src="//graystoneads.midtc.com/www/delivery/asyncjs.php"></script>					</div></div><div id="custom_html-18" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Circulars</span></h4><div class="textwidget custom-html-widget"><div id="circularhub_module_12309"></div><script src="//api.circularhub.com/12309/bb38d994bf62cb2e/circularhub_module.js"></script></div></div><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">National Video</span></h4><div class="textwidget custom-html-widget"><script type="text/javascript" src="//launch.newsinc.com/js/embed.js"></script>
<div class="inform-embed" 
    data-config-id="33684"
    data-type="VideoLauncher/Slider" 
    data-tracking-group="92991" 
    data-site-section="inform-demo-slider" 
    data-playlist-id="507"></div>
<script type="text/javascript">var _informq = _informq || [];
    _informq.push(['embed']); vid.muted = true;</script></div></div><div id="custom_html-6" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget">								<ins data-revive-zoneid="14" data-revive-id="4cbd8d8221532000f73b24d326977365"></ins>
				<script async src="//graystoneads.midtc.com/www/delivery/asyncjs.php"></script>		</div></div><div id="custom_html-8" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget">			<ins data-revive-zoneid="15" data-revive-id="4cbd8d8221532000f73b24d326977365"></ins>
			<script async src="//graystoneads.midtc.com/www/delivery/asyncjs.php"></script>		</div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-1 mh-home-wide  mh-footer-area mh-footer-4">
<div id="custom_html-16" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//www.liqwid.net/?key=031A-9BE8-85CE-D8C0';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Graystone Media		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
		<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-6686294-12']);
						_gaq.push(['_trackPageview']);
			(function() {
			 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"altustimes"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"18377 https:\/\/www.altustimes.com\/?p=18377","disqusShortname":"altustimes","disqusTitle":"Local sports round-up","disqusUrl":"https:\/\/www.altustimes.com\/sports\/18377\/local-sports-round-up","postId":"18377"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.5'></script>
<script type='text/javascript' src='https://s24467.pcdn.co/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
</body>
</html>